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Introduction
Blender is free, open source 3D modeling software. Makers and Indie game creators often use
Blender to avoid the high cost of commercial 3D software. However, commercial animation for
some TV shows (Man in the High Castle) and movies(Spiderman 2) have used Blender at least
for previsualization. NASA  has done animations using Blender. Many short Indie movies have
been created with Blender.

Blender is the “Swiss army knife” of 3D software. It creates 3D models, animates models,
renders 3D scenes, does 2D graphics within 3D worlds, creates and edits videos, does physics
simulations, has built in Python scripting, and much more. Commercial software tends to
specialize so a company has an entire pipeline of commercial software like Zbrush for modeling,
Maya for rendering, etc. Each commercial program is expensive and has a steep learning curve.
Blender does every part of the whole 3D pipeline so one program can make an entire 3D
animated movie.

Blender runs on Windows 10 computers, Mac OS, Linux, Android, and even a Raspberry Pi 4.

Blender is a Swiss army knife for modeling. A partial feature set is:
● Create 3D objects with textures and materials.
● UV Mapping for textures
● Creates 3D animations including skeletal wire frames
● Draws and animates 2D graphics with Grease Pencil.
● Creates models for 3D printing.
● Renders images and frames of videos with several different CPU and GPU rendering

engines
● Supports networked render farms
● Edits videos and even audio
● Exports 360 VR photos and 360 VR videos (equirectangular)
● Has built-in Python programming features to automate and animate objects



● Supports scientific data analysis
● Has particle system simulations (smoke, fog, hair, etc)
● Applies physics properties like gravity to objects
● Has physics fluid simulations
● Supports external add-ons to add new features
● Has a Blender marketplace where artists and programmers can sell their creations
● Used to have a Blender Game Engine, but that functionality has migrated to the open

source game engine Godot
● Commercial game engines like Unity import Blender files

The Wikipedia page https://en.wikipedia.org/wiki/Blender_(software) lists many projects that use
Blender.

Software as sophisticated as Blender has a fairly steep learning curve, especially since it is
actively improving every year. Fortunately, there are countless YouTube tutorial videos, many
books on using Blender, and commercial courses in Udemy on specialized aspects of Blender.

There is a non-profit foundation which supports the software https://www.blender.org/foundation/
and a headquarters in Amsterdam which houses employees of the foundation
https://www.blender.org/institute/.

There is a cloud based organization https://cloud.blender.org/welcome/ (Blender Cloud) which
has training, hosts movies made by Blender artists, etc. Contributions to Blender cloud help
train and support other artists.
Every year or two the Blender organization hosts the creation of an animated film called open
movies.

https://en.wikipedia.org/wiki/Blender_(software)
https://www.blender.org/foundation/
https://www.blender.org/institute/
https://cloud.blender.org/welcome/


Download and Install
The official Blender website https://www.blender.org/ has news, community support links,etc. It
also is the location to download the latest version of Blender for different operating systems.

Be sure to download the latest version of Blender. Older versions, like 2.79, have different
menus and the files are not compatible with the recent version. This document uses the latest
2.9 version of Blender.

Linux distros often have an older version of Blender in their software repositories. You even
have the option to download the source code and compile your own Blender application

After the download, installation is usually simple due to the large number of testers and users
who’ve tried the software on many different types of computers.

Launching the software is the same as starting any other program on the
local operating system. The standard desktop icon is:

https://www.blender.org/


Object Transformations and Movement
By default Blender 2.91 starts with a simple cube in the center of the 3D window.

The center area is the 3D window/ viewport where all the objects are visible. The various menus
and toolbars are around the periphery. It can seem overwhelming at first to see all the features
and options available. Blender is a complex program. Fortunately, only a few toolbar icons and
menu items are needed at first. As one explores and learns, more and more of the features
unlock their mysteries.
This central area surrounded by menus is like a window into the virtual world being created.
This window (viewport) can move around to see the scene from different angles.

The window and menu positions shown in this screen capture, and described in the rest of this
document, are the standard or default positions.

The top left toolbar has the core object movement functions.

Blender has two main modes: object Mode and Edit Mode. In object mode the tools select and
manipulate objects.



Selecting objects

In Object Mode one interacts with and manipulates objects.
when the Arrow icon is chosen on the left objects can be clicked
on and selected. Usually some orange colored border appears
when an object is selected.The triangle/ arrow icon means “select”
some object. Selection by clicking on an object is also available

when the move, rotate, and scale functions are selected.

The other way to select an object is click on it in the scene collection (upper right)

Translating Objects

The perpendicular arrows icon means move the
selected object in one of the three X,Y,Z directions.

Perpendicular arrows appear on the selected object indicating the
directions it can be moved.



Rotating Objects
The circle icon means rotate the selected object. Circles appear on the selected
object indicating the three directions it can be rotated.
Click and drag on one of the three colored circles to rotate the object around that axis.

Scaling Objects

The box icon is the scale (change size) function.
The lines and white circle indicate the directions the object can
be stretched or shrunk. Clicking on a single line stretches or
shrinks the object in that direction only. The white circle means
scale all directions uniformly.



Entering Position and Size Numerically

When creating models of precise real-world sizes, entering the position, rotation, and scale
values numerically is much more exact than click and drag.

Clicking on an object brings up its properties window/toolbar on the right side. The position and
size of the object can be set in that window. Notice the orange square is selected in the icon list.
This is the mesh object position properties.

The other way to enter sizes numerically is from the Object Mode
View drop down menu. Click on the checkbox for the sidebar or
press N on the keyboard.

The floating transform panel appears which stays there no
matter what properties panel is on the side. Notice the
Dimensions value entry fields that are on the sidebar but not on
the regular transform panel. This is handy to make objects of
precise dimensions.



Moving the User Viewpoint

To move the viewpoint in the 3D window use the middle button (scroll wheel) on the mouse, for
a desktop computer. Click and drag on the middle button rotates the point in 3-space where the
user appears to be sitting. Scrolling the middle button wheel zooms in and out. Shift click and
drag on the middle button pans around in the 3D window.

On laptops without a middle mouse button, the navigation wireframe
that appears in the upper right of the 3D workspace allows panning,
switching to orthographic views. To explore these navigation actions
blick in the circle and drag, click on the X,Y,Z axis and drag, and click
on the X,Y,Z labels to see what viewpoint movement happens.

Click on the + symbol and drag to zoom. Click on the hand and drag to
pan the viewport around.

If you accidentally pan the selected object out of the visible viewport, on the “View” menu
choose “Frame Selected” and the viewport will recenter so the selected object fills the viewport.



If the scene is really fouled up, on the File menu choose File -> New -> General and Blender
resets to a brand new file.

Blender also has keyboard shortcuts for navigation. If you have a full size desktop keyboard
with a numeric keypad, there are numeric keypad shortcuts. You can also define custom hot
keys for often used operations. Some info is at the Blender documentation page:
https://docs.blender.org/manual/en/latest/editors/3dview/navigate/navigation.html
(Note: MMB means middle mouse button)

If you do not have a middle mouse button, you can go to the Edit menu
Edit -> Preferences -> Input  and select “emulate middle mouse button”. This allows the Alt key
to replace the middle mouse button.

Orthographic Perspectives
When aligning or positioning objects it’s handy to be able to look at the
scene from above, below, front or side. These are called orthographic
perspectives. (Top, Front, Side) On the viewport movement wireframe
click on the circles with the X,Y, or Z labels and the view direction will
jump to an orthographic perspective.

All Transformations At One Time
Blender has a “Transform” icon on the left toolbar which gives you the ability to scale, rotate and
move at the same time.

The red, green, and blue circles rotate the object. The square colored blocks stretch/scale the
object, and the arrows move the object.
On the right side the “Transform” menu can be brought up with the keyboard shortcut “n”, or by
clicking on the little left arrow.

https://docs.blender.org/manual/en/latest/editors/3dview/navigate/navigation.html


The Transform window lets you enter numbers to precisely position, rotate or scale an object.
Lastly, on the far right there is a properties icon (square with corners) which gives you access to
the same transformation fields.



Light
Every scene needs a light or it's a rather boring black world. The light object when selected
looks like concentric dashed circles. In the upper right part of the screen (unless repositioned) is
the collection of objects in the scene. One can also select the light in the list of scene objects.

When the light is selected it’s properties appear in the properties window, usually on the lower
right. As you can imagine with such a flexible program, many possible lights can be created.
Other properties of the light can be customized by selecting the lightbulb icon. The color, power
and type of light can be defined. The default is a point light, but it can also be configured to be
like the sun, a spot light, or a more diffuse area light. The position of the light can be changed
with the movement tools.



Camera
Another critical object in each scene is the “Camera”. Without a camera the scene won’t be
rendered and be visible. To look through the camera and see what will be rendered, click on the
camera icon on the right side of the 3D viewport. It will toggle between the viewport and the
camera views.



Adding Mesh Objects
Note: A shortcut for the “Add”
menu is shift-A.

To add a mesh object, click on the
“Add” menu, then select “Mesh”,
then the particular shape to add.

The mesh object will be added where the 3D cursor is positioned. Notice that “Surface Project”
is checked so the 3D cursor can be on the surface of objects.



The exact position of the 3D cursor can be set on the
view properties panel on the right top. Under 3D
cursor the x,y,z position is listed and can be edited. The
next add mesh object will appear at the 3D cursor
point.

Duplicate Object

Instead of adding a new object, you can duplicate an existing object. Select the object, right
click, and choose “Duplicate Object”. Then drag the copied object around, then click again to
drop the duplicate in a new location. Three clicks-- click to select, right click of the menu, drag
the duplicate around then the third click to to drop the duplicate in a new location.



The other method is select the object, then on the object menu choose “Duplicate Object”. The
keyboard shortcut is “shift D”

Snap Tool

Aligning objects is tedious although it’s possible with the orthogonal views and move tool. An
easier way is to select the object, click on the move tool, then click on the snap tool which is at
the top center and looks like a magnet. When moving an object (including a duplicated object) it
snaps to grid lines instead of smoothly sliding. If the scene is viewed from an orthogonal angle
(side, top, front), it is easier to duplicate and snap objects in alignment.



Add Background Image
In Object Mode, to the top level Add menu, then Add - >Image -> Background and select the file
you want as a background. Move and scale as desired.



To delete an object, select the object and press “x” on
the keyboard. Confirm deletion from the menu that pops
up. Alternatively, select and object and right click. From
the menu select “Delete”

Combining Objects

Join
To combine or join two or more objects into a single object, select the objects with shift-click,
then CTRL-J or select from the Object menu, Join.

Measure
The measure tool, which
looks like a protractor, lets
you find the distance between
two points by drawing a line.



After joining, the multiple objects will behave like one object for materials, texturing, etc.

Object Name
As objects are added to the scene, a good strategy is to change the object names in the
collection list.



Add Background Image

Add Image That Won’t Render
To add an image as a reference, that won’t appear in the final render, in Object mode, on the
Add menu, choose Image, then Background.
Add -> Image -> Background

From somewhere on your computer select the desired image. It will be placed in the scene
where the cursor is located.

In the Layout view this background image will appear in the standard 3D viewport.

Such an image is used as a reference for drawing or modeling. Here’s an example of the sky
background image behind the cube.



All the objects like Camera or light will be visible, unlike in the rendered image.

To Add an Image That Will Appear in the Render
For an image to appear in the render, it must be added as a texture on a mesh plane. From the
“Add” menu insert a mesh->Plane. Then use an image as a texture. This operation is so
common there is a Blender Add-on that does this. On the Edit->Preferences menu, select
Add-on, then search for Image. Select the “Import Images as Planes”. Then

Then on the Add menus there will be a new option, Add->Image->Images as Planes



This will add the image as a texture on a plane which will render. The square behind the cube is
the plane that was added, but without the image texture. That image will only appear after
rendering.

The image you loaded will not appear in the Layout view but will appear in the Rendered image.
The rendered image of the sky and cube is later in this document as an example in the “Render
an Image” section.

It is tricky to get the background image perpendicular to the camera so it looks good.

Render an Image
When done modeling, on the “Render” menu select “Render Image”, or choose F12 as the
keyboard shortcut.

Depending on your computer and GPU, and the complexity of the image, it can take a long time
to render an image.

To set the image size, choose the icon that looks like a printer on the right side. X, Y resolution
properties are set there.



On this same “print” properties panel, unter the Output drop down, the image file format can be
selected.

Below is a rendered image using the cube and the Image as a Plane add on as background.



Here’s a sky image behind the cube. By Jessie Eastland - Own work, CC BY-SA 4.0

To save the rendered image (in the Render view window) choose the Image->Save menu item.

Edit Mode
The initial Object Mode lets users create, move, rotate, and scale objects. To change vertices,
edges, and faces switch to Edit Mode.



The drop down menu in the upper left contains the Edit Mode option.

The keyboard shortcut to switch to Edit Mode is the TAB key. The TAB key will also switch back
to object mode.
The toolbar on the left part of the screen changes in Edit Mode.
The standard transformation tools are still there (move, rotate, scale, transform) although they
work differently. The annotate and measure tools are there, as well but new tools are added
below on the toolbar. These are extrude, bevel,etc.

When in Edit Mode, the transform tools (scale, rotate, etc) will transform the selected face or
edge instead of the entire object like in Object Mode.

Note: select the object in Object Mode, then switch to Edit Mode to transform parts of the object.

Selection
Select a vertex, edge or face with the selection mode selector at top left

The three icons next to the Mode menu are to select items.

The left icon selects vertices (nodes)

The middle icon selects edges.



The right icon selects faces.
After clicking on the appropriate icon, select the components (nodes, edges, faces) on the main
modeling area.

Shift click will let you enable all three selection modes and Blender will guess whether you’re
picking a node, edge, or face.

This multi-select mode is handy when the model is simple but for complex and dense models,
it’s hard for Blender to guess what object you’re picking.

As long as the emulate number pad is not selected, the
keyboard shortcut is type the numbers 1,2,or 3 which will set
the selection mode to vertex or edge or face.

Context Menus
When something is selected on an object, right click and a
context menu will appear.

For example, when a vertex is selected, right click brings up:



With an edge selected, right click give the menu: ,

With a face selected, right click gives the menu:



Delete
Select a vertex, edge or face, then press the DELETE key or the
X key to bring up the delete menu. Depending on what’s selected,
something will be eliminated leaving edges, vertices, or nothing.



The other option is to select something and right click to get the
context menu and choose delete. In this screenshot an edge was
selected and the context menu was to delete an edge.

Fill In
When two edges or two vertices are selected using SHIFT select, the F key will fill in what’s
between the two, creating either a new line or a face.

Move, Rotate, Resize
If you select an entire object, then in Edit Mode, type the letter S, then a number such as 2, the
mesh data is scaled by a factor of 2 in all directions. In the lower left is a box which lists the last
operation. It shows the resize action in this example.



The resize makes the actual mesh data larger, not the object. Back in Object Mode the object
will still have a scale factor the same as before, probably 1 for the default cube.

In edit mode, the position can be changed. For example, with a cube of size 2, the keys G Z 2
will move the cube up two units in the Z direction. Handy to make an object sit on the ground
where Z=0.

Extrude
In Edit Mode, after selecting a vertex, edge, or face, either right click to get the context menu, or
select the extrude tool on the right toolbar.

The circle + control appears on the selected object, in this case the selected face.
Click and drag to extrude.



Extrude Edge
First select an edge, right click then click Extrude. Extrude an edge,

Extrude Face

In this example, the face was triangulated (right context menu) then extruded.



Extrude Vertex
Select a vertex then either extrude on the right click context menu, or the Extrude tool. Pulling
on the vertex will move just that vertex outward. It becomes a thin black line stretching back to
its original location.

Bevel
Go into edit mode (Tab)

To bevel an edge, click edge (or two vertices in vertex mode)
Then click bevel tool or CTRL+B

Click and drag the ball stick upward to bevel the edge. While holding down the mouse, roll the
mouse wheel to increase the subdivisions.



Select a face and the bevel tool to bevel all edges connected to the face.

Materials
Materials are how colors, reflective properties and images are added to objects.
Back in object mode, click on the world icon on the right properties panel.

If it is a different object than was selected before, Add new material

Give the material a name, then change properties like base color.



A material can have properties adjusted from 0.0 to 1.0. For
example, it can be made metallic, or specular (reflective),
or roughness (from shiny to matte), clear coat for reflective
car look, etc.


